Products

LEGO Harry Potter: Years 1-4 (box): £13.99
LEGO Harry Potter: Years 5-7 (box): £13.99

 

System requirements:

  • DVD drive
  • Mac OS X 10.6
  • 1.4GHz Intel Mac Core Duo
  • 8GB HDD
  • 1024MB RAM
  • LEGO Harry Potter Years 1-4 does not support NVIDIA 7xxx series or Intel GMA series graphics cards.
  • Full system requirements are available on the LEGO Harry Potter Years 1-4 mini-site at feralinteractive.com/legoharrypotter .
  • If you encounter problems playing the game, please visit support.feralinteractive.com and contact our support team. This allows us to deal with your issue quickly, and helps us to improve our games.
  • The Ministry of Magic strongly advises that this game should be played out of sight of Muggles.

 

News

18.01.2011:

LEGO Harry Potter: Years 1-4 is shipping

The English version of LEGO Harry Potter: Years 1-4 for the Mac is shipping.

 

Copyright © 2017 Application Systems London | Contact | Terms