Products

LEGO Harry Potter: Years 1-4 (box): £13.99
LEGO Harry Potter: Years 5-7 (box): £13.99

 

System requirements:

  • DVD drive
  • Mac OS X 10.6
  • 7GB HDD
  • 2048MB RAM
  • 128MB VRAM
  • The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, NVIDIA 9400, NVIDIA 7xxx series and Intel GMA series. The following cards require you to have 4GB of System RAM: NVIDIA 320M, NVIDIA 9400, Intel HD 3000

 

News

28.03.2012:

LEGO Harry Potter: Years 5-7 is shipping

The English download version of LEGO Harry Potter: Years 5-7 for the Mac is shipping. Box version will follow soon.

 

Copyright © 2019 Application Systems London | Contact | Terms | Privacy Policy